Ubuntu Edgy 6.10 to Feisty 7.04 upgrade: sound and video issues

Since late November 2006, I had Ubuntu Edgy 6.10 running on my Toshiba Satellite A100-TA6. I wrote a full report on that here.

So, I decided to take the plunge and upgrade to Feisty 7.04, and so the adventure begins.

Intel High Definition Audio (HDA) Sound Problems

My laptop has an Intel HDA sound card.

After the upgrade to Feisty, the sound had very low volume, and the mic barely worked. Moreover, everything I spoke in the mic came through the headphones s well.

This is very annoying since I use Skype a lot on my laptop to stay in touch with various people around the world.

The solution was simple: in the file /etc/modprobe.d/alsa-base add this at the very end.

options snd-hda-intel model=3stack

Intel 945GM video

The Intel i810 driver for the xorg X11 server had a problem with suspend/hibernate. I switched to the vesa driver to get around this problem.

This workaround has some drawbacks:

  • Cannot change screen resolutions. This is means I cannot use external projectors which work at 1024x768. The 915resolution program provides this feature by modifying the BIOS on the fly.
  • No hardware acceleration for graphics and video (not a big deal in my case.

So, I was eager to update to Feisty, since I thought this problem was fixed.

However, I ran into a new problem that prevents me from using the intel driver (which replaces the i810 driver).

I can't describe it well in words. On the KDM screen, the buttons do work (the enter button as well as the button that pops up a menu). However, the text is way too large and shifted to the right.

Here is a picture to better describe what I saw.

Ubuntu Feisty 7.04 xorg Intel i810 945GM problem 

If you find a solution to this, please let me know.

Contents: 

Comments

Using "i810" package not "intel"

I noticed that Feisty has a new package name xserver-xorg-video-intel which replaces the older xserver-xorg-video-i810 (note the version numbers). The README in the source tar.gz for the xserver-xorg-video-intel package says this:

Common issues not caused by the driver - Font sizes (DPI) are wrong. Some displays incorrectly report their physical size, which is harmless on most OSes that always assume 96dpi displays. This can be fixed through quirks for specific monitors in the X Server, and the output of xrandr --prop along with a physical measurement of the screen size in a bug report against the server can help get that fixed.

I tried setting this in xorg.conf to fix the DPI. DisplaySize 338 212 However that did not work either. So, what I did was: a) Install xserver-xorg-video-i810 (2:1.7.4-0ubuntu1) using aptitude. The install of the i810 package automatically removed the -intel package. b) Uninstall the 915resolution package. c) Then in /etc/default/acpi-support, I set: POST_VIDEO=false d) In /etc/X11/xorg.conf, I now have: Section "Device" Identifier "Intel i945" Driver "i810" Option "VBERestore" "True" Option "Dri" "True" BusID "PCI:0:2:0" EndSectionThe good news is after I did this, I am able to do the following things, which were not possible with the vesa driver (with the exception of the hibernate)):

  1. Cycle through the resolutions using Ctrl-Alt-+/-
  2. Send the output to the external VGA port by the Fn key combo.
  3. Resuming from hibernate works well too.

The only drawback is that I am not sure if this is a sustainable solution though, since the -i810 package is replaced by the -intel package which does not work, and will be the only package in Gutsy.By the way, all this is now reported in my previous bug report on launchpad. -- Khalid Baheyeldin

thanks for the help

Thank you for taking the time to post this. I have a Toshiba A135 and I was having difficulties configuring the sound card but using model=3stack works perfectly.